Eclipse中java8使用javafx问题

Eclipse第一次使用JDK8来构建javafx遇上编译型错误:

1
2
3
Access restriction: The type 'Application' is not API (restriction on required library 'D:\Java\jdk1.8\jre\lib\ext\jfxrt.jar')

解决方案:项目名称右键-->Build Path-->Confgure Build Path-->选择jre system library-->remove-->Add library 重新添加系统jre库

Eclipse中java8使用javafx问题

https://preccrep.github.io/2020/07/02/API/

Author

preccrep

Posted on

2020-07-02

Updated on

2020-07-02

Licensed under

You need to set install_url to use ShareThis. Please set it in _config.yml.
You forgot to set the business or currency_code for Paypal. Please set it in _config.yml.

Comments

You forgot to set the shortname for Disqus. Please set it in _config.yml.
You need to set client_id and slot_id to show this AD unit. Please set it in _config.yml.